设为首页收藏本站

搜索
Hi~登录注册
查看: 713|回复: 0

我弄了个D3D9透视,所用的Stride被其他的Stride遮到了无法透过去

[复制链接]

1

主题

3

帖子

3

积分

一级雷锋

Rank: 1

积分
3
发表于 2018-9-17 13:31:18 | 显示全部楼层 |阅读模式
我弄了个D3D9透视,所用的Stride被其他的Stride遮到了无法透过去: u' k  n/ _- h' I. X' X& |5 W- V' S0 L

- M% r! B8 H) ^& m$ ], p3 d# F用身体或草可以透
: t* g; J# ~. l* n' C0 V, ~7 X墙和房屋就不行了.(不在同一个Stride)
4 V) K; \& h# a* \% D
4 w7 \6 m* l( }& o) [  t; @3 f4 Y! u! E: Z
求大神怎么解决啊
  ^4 D" h, \4 z5 @$ V( L+ w.版本 2- T! h( x5 r( u# S
.支持库 spec# P9 m4 X! X( O1 w9 S+ r# ?# h; h
: K& F* {4 N1 t" @; ~' Z% C) T, c1 r
.如果真 (GetStreamSource (pDevice, 0, 取变量数据地址 (Stream_Data), 取变量数据地址 (Offset), 取变量数据地址 (Stride)) = #D3D_OK)
" k4 |+ u, {/ @6 [- ]+ P7 L! J    Release (Stream_Data): t8 ~/ F" N/ r8 {7 T- A/ D- a+ E
.如果真结束8 T7 L" c3 \1 j, p) b6 W
.如果真 (Stride = 24 )  ' 38 40 48( k4 _: {8 |$ Q  K
    SetRenderState (pDevice, #D3DRS_ZENABLE, #false)
8 h; j, x$ t$ Z    SetRenderState (pDevice, #D3DRS_FILLMODE, #D3DFILL_SOLID)
8 }' i! H. I. {) \, \    ' ==========人物上色 墙后上色7 X" Z: Z! O9 w

8 ?  [( n& T6 B( C/ m# q! K    SetRenderState (pDevice, #D3DRS_ZENABLE, #false)
5 |6 _$ Z$ Y" b3 L5 ^    SetRenderState (pDevice, #D3DRS_FILLMODE, #D3DFILL_SOLID)
8 M5 ~! c' L( Z) I8 X    SetTexture (pDevice, 0, g_pTexGreen)# k3 O: A0 Z: p4 |
    ' ================上色2 D9 R4 a) f/ Y9 @" Z
    oDrawIndexedPrimitive (pDevice, dType, BaseVertexIndex, MinVertexIndex, NumVertices, startIndex, PrimitiveCount)
  H0 C. B8 q$ ?4 Z: f. h    SetRenderState (pDevice, #D3DRS_ZENABLE, #true)6 O, N' {% \; K0 H# F/ ~6 I) X
    SetRenderState (pDevice, #D3DRS_FILLMODE, #D3DFILL_SOLID)
6 n/ Z6 y9 E3 ^0 m5 \    ' ===============人物上色 面前上色
, O" p* L+ z* `; A7 i1 J  b    SetTexture (pDevice, 0, g_pTexRed)& Q6 I  f) m) `2 v9 z" V4 T6 \
.如果真结束; i: C" X" Z& n
返回 (oDrawIndexedPrimitive (pDevice, dType, BaseVertexIndex, MinVertexIndex, NumVertices, startIndex, PrimitiveCount))% Z3 [9 E7 u7 g! g2 b3 b




上一篇:刺激战场的辅助具体开发视频资源哪位大神手里有,求一点
下一篇:只有易语言部分 c++ 部分刚开始讲 就没了 ...
回复

使用道具 举报

游客
回复
 懒得打字嘛,点击右侧快捷回复【左侧自定义内容】  【右侧自定义内容】
您需要登录后才可以回帖 登录 | 立即注册

快速回复 返回顶部 返回列表